November, 2025
Incident Updates
Maintenance Completed
Honkai Star Rail - Version Update 3.7.0
Updates
-
We have deployed a metadata update and are monitoring the rollout. Please restart your launcher to receive.
As always, we'll keep you updated should the situation evolve. Please report any issues via official channels.
-
Maintenance has begun for Honkai: Star Rail. As with every update, we will be pushing new metadata to re-enable repair functionality. We'll update this post when that's done.
-
The game will be updated to version 3.7.0: As Tomorrow Became Yesterday!
For more information regarding the update patch notes, please visit HoYoLab: https://www.hoyolab.com/article/42064026
During this period, certain Collapse systems will not work as intended, notably:
- Game Repair
- Cache Update
- Game File Clean-Up
Other systems such as:
- Game Installation
- Game Update
Should continue to work as intended.
A metadata update and/or launcher update may be required for our users, we will update this notice and make an annoucement on Discord should that be the case.
RESOLVED
Collapse Site DOWN
Updates
- INVESTIGATING
collapselauncher.com is DOWN
Monitor Name: Collapse Site
Incident Status: TRIGGERED
Severity: critical
Monitor Status: DOWN
Monitor Health Checks: 1
Monitor Failure Threshold: 1
- RESOLVED
The incident has been auto resolved, Total downtime: 0 minutes
RESOLVED
Collapse Site DOWN
Updates
- RESOLVED
The incident has been auto resolved, Total downtime: 0 minutes
- INVESTIGATING
collapselauncher.com is DOWN
Monitor Name: Collapse Site
Incident Status: TRIGGERED
Severity: critical
Monitor Status: DOWN
Monitor Health Checks: 1
Monitor Failure Threshold: 1
RESOLVED
Collapse Site DOWN
Updates
- INVESTIGATING
collapselauncher.com is DOWN
Monitor Name: Collapse Site
Incident Status: TRIGGERED
Severity: critical
Monitor Status: DOWN
Monitor Health Checks: 1
Monitor Failure Threshold: 1
- RESOLVED
The incident has been auto resolved, Total downtime: 0 minutes
RESOLVED
Collapse Site DOWN
Updates
- RESOLVED
The incident has been auto resolved, Total downtime: 10 minutes
- INVESTIGATING
collapselauncher.com is DOWN
Monitor Name: Collapse Site
Incident Status: TRIGGERED
Severity: critical
Monitor Status: DOWN
Monitor Health Checks: 1
Monitor Failure Threshold: 1
RESOLVED
Collapse Site DOWN
RESOLVED
Collapse Site DOWN
Updates
- RESOLVED
The incident has been auto resolved, Total downtime: 0 minutes
- INVESTIGATING
collapselauncher.com is DOWN
Monitor Name: Collapse Site
Incident Status: TRIGGERED
Severity: critical
Monitor Status: DOWN
Monitor Health Checks: 1
Monitor Failure Threshold: 1
Maintenance Completed
Zenless Zone Zero - Version Update 2.3.0
Updates
-
The game will be updated to version 2.4.0: On the Precipice of the Abyss!
For more information regarding the update patch notes, please visit HoYoLab: https://www.hoyolab.com/article/42466149
During this period, certain Collapse systems will not work as intended, notably:
- Game Repair
- Cache Update
- Game File Clean-Up
Other systems such as:
- Game Installation
- Game Update
Should continue to work as intended.
A metadata update and/or launcher update may be required for our users, we will update this notice and make an annoucement on Discord should that be the case.
-
Maintenance has begun about 2.5 hours ago.
We've begun deployment of the necessary backend changes to support version 2.4.0.
Please restart your launcher to receive the update. Please keep in mind that due to the nature of CDNs, it may take some time for the update to propagate.
As always, we're keeping our eyes open on any issues via our official channels.