December, 2025
Incident Updates
Maintenance Completed
Genshin Impact - Version Update 6.2.0
Updates
-
An update has been deployed for Global users to re-enable functionality.
Due to unforeseen circumstances, CN players will be receiving this update at a later date.
Thank you for your understanding and your continued support.
-
Maintenance has started on all regions. We'll be pushing a metadata update soon to support the new version.
Thank you for your patience.
-
The game will be updated to version 6.2.0: Luna III!
For more information regarding the update patch notes, please visit HoYoLab: https://www.hoyolab.com/article/42577649
During this period, certain Collapse systems will not work as intended, notably:
- Game Repair
- Cache Update
- Game File Clean-Up
Other systems such as:
- Game Installation
- Game Update
Should continue to work as intended.
A metadata update and/or launcher update may be required for our users, we will update this notice and make an annoucement on Discord should that be the case.
RESOLVED
Collapse Site DOWN
Updates
- RESOLVED
The incident has been auto resolved, Total downtime: 0 minutes
- INVESTIGATING
collapselauncher.com is DOWN
Monitor Name: Collapse Site
Incident Status: TRIGGERED
Severity: critical
Monitor Status: DOWN
Monitor Health Checks: 1
Monitor Failure Threshold: 1
RESOLVED
Collapse Site DOWN
Updates
- INVESTIGATING
collapselauncher.com is DOWN
Monitor Name: Collapse Site
Incident Status: TRIGGERED
Severity: critical
Monitor Status: DOWN
Monitor Health Checks: 1
Monitor Failure Threshold: 1
- RESOLVED
The incident has been auto resolved, Total downtime: 0 minutes
Maintenance Completed
Honkai: Star Rail - Version Update 3.8.0
Updates
-
A fix was deployed via metadata. Please restart to receive.
Thank you for your continued support.
-
We've identified an issue where Collapse is unable to recognize installations after updating to the newest version.
In such cases, we encourage you to use the official launcher until we confirm that the issue is resolved.
We apologize for the inconvenience and thank you for your understanding and patience regarding this matter.
-
We're deploying a metadata update to re-enable Cache features across all regions.
Please be advised that we have disabled Game Repair for CN regions due to some issues with the upstream content HoYoVerse is serving. We'll re-enable it and post a new notice on Discord once the matter is resolved.
Thank you.
-
Maintenance has begun across all regions.
A metadata update will be required to access repair features. We'll post an update when that's done!
-
The game will be updated to version 3.8.0: Memories are the Prelude to Dreams!
For more information regarding the update patch notes, please visit HoYoLab: https://hoyo.link/6T67wqRkz
During this period, certain Collapse systems will not work as intended, notably:
- Game Repair
- Cache Update
- Game File Clean-Up
Other systems such as:
- Game Installation
- Game Update
Should continue to work as intended.
A metadata update and/or launcher update may be required for our users, we will update this notice and make an annoucement on Discord should that be the case.
RESOLVED
Collapse Site DOWN
Updates
- RESOLVED
The incident has been auto resolved, Total downtime: 0 minutes
- INVESTIGATING
collapselauncher.com is DOWN
Monitor Name: Collapse Site
Incident Status: TRIGGERED
Severity: critical
Monitor Status: DOWN
Monitor Health Checks: 1
Monitor Failure Threshold: 1
RESOLVED
Collapse Site DOWN
RESOLVED
Collapse Site DOWN
Updates
- INVESTIGATING
collapselauncher.com is DOWN
Monitor Name: Collapse Site
Incident Status: TRIGGERED
Severity: critical
Monitor Status: DOWN
Monitor Health Checks: 1
Monitor Failure Threshold: 1
- RESOLVED
The incident has been auto resolved, Total downtime: 0 minutes
Maintenance Completed
Zenless Zone Zero - Update 2.5.0
Updates
-
We've deployed a metadata update. Please restart your launcher to receive.
For those that had an issue with Collapse downloading missing files, the metadata update should resolve the issues. If you continue encoutering them, please don't hesitate to reach out to us via the official channels.
Thanks!
-
Maintenance has begun. We'll be issuing a metadata update when possible.
Please note that Collapse currently has issues with the update and is re-downloading deleted mission resources.
We'll update this notice as the situation unfolds.
-
The game will be updated to version 2.5.0: To Be Fuel for the Night!
For more information regarding the update patch notes, please visit HoYoLab: https://www.hoyolab.com/article/42972295
During this period, certain Collapse systems will not work as intended, notably:
- Game Repair
- Cache Update
- Game File Clean-Up
Other systems such as:
- Game Installation
- Game Update
Should continue to work as intended.
A metadata update and/or launcher update may be required for our users, we will update this notice and make an annoucement on Discord should that be the case.